# Ad Inserter – Ad Manager & AdSense Ads <= 2.8.19 - Authenticated (Contributor+) Stored Cross-Site Scripting via adinserter Shortcode Attribute Placeholders

- **ID:** WPSEC-2026-1944
- **Plugin:** Ad Inserter – Ad Manager & AdSense Ads (`ad-inserter`), https://wordpress.org/plugins/ad-inserter/
- **Affected versions:** all versions before 2.8.20
- **Fixed in:** 2.8.20 (Update to 2.8.20 or later.)
- **Severity:** Medium 4.9 (CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-10-29)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/ad-inserter
- **Fix released:** 2026-10-28
- **Published:** 2026-10-29
- **URL:** https://wpsec.com/vuln/WPSEC-2026-1944/

## Description

The Ad Inserter plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the attributes of the 'adinserter' shortcode in all versions up to, and including, 2.8.19. This is due to insufficient output escaping: replace_ai_tags() substitutes shortcode attribute values directly into the {#name#} placeholders of the block code. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts that execute whenever a user accesses an injected page, on sites where a block's code uses such placeholders.

## References

- https://wpsec.com/vuln/WPSEC-2026-1944/
- https://plugins.svn.wordpress.org/ad-inserter/tags/2.8.20/
- https://wordpress.org/plugins/ad-inserter/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-1944/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
