# User Frontend <= 4.3.13 - Unauthenticated Stored Cross-Site Scripting via Category Name

- **ID:** WPSEC-2026-1946
- **Plugin:** User Frontend – Membership, User Registration, User Profile, User Directory & Content Restriction with Frontend Post Submission (`wp-user-frontend`), https://wordpress.org/plugins/wp-user-frontend/
- **Affected versions:** all versions before 4.3.14
- **Fixed in:** 4.3.14 (Update to 4.3.14 or later.)
- **Severity:** Medium 5.4 (CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-10-29)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/wp-user-frontend
- **Fix released:** 2026-10-28
- **Published:** 2026-10-29
- **URL:** https://wpsec.com/vuln/WPSEC-2026-1946/

## Description

The User Frontend plugin for WordPress is vulnerable to Stored Cross-Site Scripting via taxonomy term names in all versions up to, and including, 4.3.13 due to term names being output without escaping in the Vue-mounted admin form builder, allowing both HTML and Vue template injection. This makes it possible for unauthenticated attackers, where a frontend form lets guests submit new category terms, to inject arbitrary web scripts that execute when an administrator opens that form in the form builder.

## References

- https://wpsec.com/vuln/WPSEC-2026-1946/
- https://plugins.svn.wordpress.org/wp-user-frontend/tags/4.3.14/
- https://wordpress.org/plugins/wp-user-frontend/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-1946/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
