# User Frontend <= 4.3.13 - Reflected Cross-Site Scripting via Category Field

- **ID:** WPSEC-2026-1950
- **Plugin:** User Frontend – Membership, User Registration, User Profile, User Directory & Content Restriction with Frontend Post Submission (`wp-user-frontend`), https://wordpress.org/plugins/wp-user-frontend/
- **Affected versions:** all versions before 4.3.14
- **Fixed in:** 4.3.14 (Update to 4.3.14 or later.)
- **Severity:** Medium 6.1 (CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-10-29)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/wp-user-frontend
- **Fix released:** 2026-10-28
- **Published:** 2026-10-29
- **URL:** https://wpsec.com/vuln/WPSEC-2026-1950/

## Description

The User Frontend plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the category field of frontend forms in all versions up to, and including, 4.3.13 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a crafted link.

## References

- https://wpsec.com/vuln/WPSEC-2026-1950/
- https://plugins.svn.wordpress.org/wp-user-frontend/tags/4.3.14/
- https://wordpress.org/plugins/wp-user-frontend/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-1950/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
