{
 "id": "WPSEC-2026-1959",
 "url": "https://wpsec.com/vuln/WPSEC-2026-1959/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-1959/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-1959/index.md",
 "title": "Premium Packages <= 7.3.0 - Authenticated (Subscriber+) Insecure Direct Object Reference to Guest Order Takeover",
 "description": "The Premium Packages plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 7.3.0 due to missing ownership validation when linking guest orders to user accounts through the 'resolveorder' AJAX action, the 'invoice' field on the login and registration forms, and the order view page. This makes it possible for authenticated attackers, with subscriber-level access and above, to link any unassigned guest order to their own account using only its order ID, gaining access to the guest buyer's purchased downloads and billing information. Where user registration is enabled, this can be performed by unauthenticated visitors through the signup form.",
 "plugin": {
  "slug": "wpdm-premium-packages",
  "name": "Premium Packages",
  "full_name": "Premium Packages – Sell Digital Products Securely",
  "wordpress_org": "https://wordpress.org/plugins/wpdm-premium-packages/",
  "advisories_url": "https://wpsec.com/vuln/plugin/wpdm-premium-packages/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/wpdm-premium-packages"
 },
 "type": "IDOR",
 "cwe": [
  "CWE-639"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 5.4,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "7.3.1",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 7.3.1"
  ]
 },
 "introduced_in": null,
 "fixed_in": "7.3.1",
 "remediation": "Update to 7.3.1 or later.",
 "fix_released": "2026-10-28T16:32:39+00:00",
 "published": "2026-10-29T18:50:39+00:00",
 "updated": "2026-10-29T17:47:39.937407+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-1959/",
  "https://plugins.svn.wordpress.org/wpdm-premium-packages/tags/7.3.1/",
  "https://wordpress.org/plugins/wpdm-premium-packages/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/wpdm-premium-packages",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Low",
  "affected_versions": "Low",
  "as_of": "2026-10-29"
 }
}