# Premium Packages <= 7.3.0 - Unauthenticated Insecure Direct Object Reference to Guest Billing Information Update

- **ID:** WPSEC-2026-1961
- **Plugin:** Premium Packages – Sell Digital Products Securely (`wpdm-premium-packages`), https://wordpress.org/plugins/wpdm-premium-packages/
- **Affected versions:** all versions before 7.3.1
- **Fixed in:** 7.3.1 (Update to 7.3.1 or later.)
- **Severity:** Low 3.7 (CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N)
- **Weakness:** CWE-639
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-10-29)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/wpdm-premium-packages
- **Fix released:** 2026-10-28
- **Published:** 2026-10-29
- **URL:** https://wpsec.com/vuln/WPSEC-2026-1961/

## Description

The Premium Packages plugin for WordPress is vulnerable to Insecure Direct Object Reference via the 'update_guest_billing' AJAX action in all versions up to, and including, 7.3.0, due to the handler trusting any encrypted order ID supplied in the 'oid' parameter without verifying that the requester owns the order. This makes it possible for unauthenticated attackers who obtain an encrypted order reference, including values encrypted with the same key in other contexts such as password reset links, to overwrite the billing information of other customers' orders.

## References

- https://wpsec.com/vuln/WPSEC-2026-1961/
- https://plugins.svn.wordpress.org/wpdm-premium-packages/tags/7.3.1/
- https://wordpress.org/plugins/wpdm-premium-packages/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-1961/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
