{
 "id": "WPSEC-2026-1970",
 "url": "https://wpsec.com/vuln/WPSEC-2026-1970/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-1970/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-1970/index.md",
 "title": "Fast Velocity Minify <= 3.5.7 - Unauthenticated Stored Cross-Site Scripting via HTML Parser Placeholder Injection",
 "description": "The Fast Velocity Minify plugin for WordPress is vulnerable to Stored Cross-Site Scripting via its bundled HTML parser in all versions up to, and including, 3.5.7. The cause is predictable internal noise placeholders, regex-based stashing of comments, script and style blocks that ignored attribute boundaries, and unescaped restoration of stashed content into attribute values. Every front-end page is re-parsed and re-serialized, so placeholder text or comment/script openers placed inside an attribute value can close the attribute early and inject new markup. This makes it possible for unauthenticated attackers who can submit HTML content such as comments with allowed attributes, as well as contributors through post content, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.",
 "plugin": {
  "slug": "fast-velocity-minify",
  "name": "Fast Velocity Minify",
  "full_name": "Fast Velocity Minify",
  "wordpress_org": "https://wordpress.org/plugins/fast-velocity-minify/",
  "advisories_url": "https://wpsec.com/vuln/plugin/fast-velocity-minify/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/fast-velocity-minify"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 7.2,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N",
  "severity": "High"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "3.5.8",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 3.5.8"
  ]
 },
 "introduced_in": null,
 "fixed_in": "3.5.8",
 "remediation": "Update to 3.5.8 or later.",
 "fix_released": "2026-10-28T19:32:58+00:00",
 "published": "2026-10-29T19:43:39+00:00",
 "updated": "2026-10-29T17:47:34.442277+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-1970/",
  "https://plugins.svn.wordpress.org/fast-velocity-minify/tags/3.5.8/",
  "https://wordpress.org/plugins/fast-velocity-minify/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/fast-velocity-minify",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Low",
  "affected_versions": "Low",
  "as_of": "2026-10-29"
 }
}