# Fast Velocity Minify <= 3.5.7 - Unauthenticated Stored Cross-Site Scripting via HTML Parser Placeholder Injection

- **ID:** WPSEC-2026-1970
- **Plugin:** Fast Velocity Minify (`fast-velocity-minify`), https://wordpress.org/plugins/fast-velocity-minify/
- **Affected versions:** all versions before 3.5.8
- **Fixed in:** 3.5.8 (Update to 3.5.8 or later.)
- **Severity:** High 7.2 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-10-29)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/fast-velocity-minify
- **Fix released:** 2026-10-28
- **Published:** 2026-10-29
- **URL:** https://wpsec.com/vuln/WPSEC-2026-1970/

## Description

The Fast Velocity Minify plugin for WordPress is vulnerable to Stored Cross-Site Scripting via its bundled HTML parser in all versions up to, and including, 3.5.7. The cause is predictable internal noise placeholders, regex-based stashing of comments, script and style blocks that ignored attribute boundaries, and unescaped restoration of stashed content into attribute values. Every front-end page is re-parsed and re-serialized, so placeholder text or comment/script openers placed inside an attribute value can close the attribute early and inject new markup. This makes it possible for unauthenticated attackers who can submit HTML content such as comments with allowed attributes, as well as contributors through post content, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

## References

- https://wpsec.com/vuln/WPSEC-2026-1970/
- https://plugins.svn.wordpress.org/fast-velocity-minify/tags/3.5.8/
- https://wordpress.org/plugins/fast-velocity-minify/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-1970/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
