# Events Made Easy <= 3.3.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via Location Map Shortcode Attributes

- **ID:** WPSEC-2026-1976
- **Plugin:** Events Made Easy (`events-made-easy`), https://wordpress.org/plugins/events-made-easy/
- **Affected versions:** all versions before 3.3.2
- **Fixed in:** 3.3.2 (Update to 3.3.2 or later.)
- **Severity:** Medium 6.4 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-10-29)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/events-made-easy
- **Fix released:** 2026-10-28
- **Published:** 2026-10-29
- **URL:** https://wpsec.com/vuln/WPSEC-2026-1976/

## Description

The Events Made Easy plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'width', 'height' and 'zoom' attributes of the plugin's location map shortcodes ([eme_location_map], [eme_locations_map], [locations_map], [display_single_location]) in all versions up to, and including, 3.3.1. This is due to insufficient input sanitization and output escaping: the attribute values pass only through sanitize_text_field(), which leaves single quotes intact, and are then placed inside single-quoted HTML attributes (the map container's style attribute and data-zoom_factor). This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

## References

- https://wpsec.com/vuln/WPSEC-2026-1976/
- https://plugins.svn.wordpress.org/events-made-easy/tags/3.3.2/
- https://wordpress.org/plugins/events-made-easy/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-1976/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
