# Media Library Assistant <= 3.43 - Authenticated (Contributor+) Sensitive Information Exposure via 'parent:post_password' Substitution Parameter

- **ID:** WPSEC-2026-1981
- **Plugin:** Media Library Assistant (`media-library-assistant`), https://wordpress.org/plugins/media-library-assistant/
- **Affected versions:** all versions before 3.44
- **Fixed in:** 3.44 (Update to 3.44 or later.)
- **Severity:** Medium 4.3 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N)
- **Weakness:** CWE-200
- **Usage among sites WPSec scans:** plugin Low, affected versions None seen (as of 2026-10-29)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/media-library-assistant
- **Fix released:** 2026-10-28
- **Published:** 2026-10-30
- **URL:** https://wpsec.com/vuln/WPSEC-2026-1981/

## Description

The Media Library Assistant plugin for WordPress is vulnerable to Sensitive Information Exposure via the 'parent:' field-level substitution parameter of its shortcodes in all versions up to, and including, 3.43, due to mla_expand_field_level_parameters() returning any property of the parent post, including post_password. This makes it possible for authenticated attackers with contributor-level access and above to reveal the passwords of password-protected posts and pages that have attached media items.

## References

- https://wpsec.com/vuln/WPSEC-2026-1981/
- https://plugins.svn.wordpress.org/media-library-assistant/tags/3.44/
- https://wordpress.org/plugins/media-library-assistant/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-1981/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
