{
 "id": "WPSEC-2026-1983",
 "url": "https://wpsec.com/vuln/WPSEC-2026-1983/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-1983/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-1983/index.md",
 "title": "Media Library Assistant <= 3.43 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode Attributes",
 "description": "The Media Library Assistant plugin for WordPress is vulnerable to Stored Cross-Site Scripting via attributes of its shortcodes, including mla_gallery, mla_custom_list, mla_archive_list and mla_term_list, in all versions up to, and including, 3.43. This is due to insufficient input sanitization and output escaping of values such as the 'unit' attribute, 'mla_nolink_text' (sanitized before template substitution rather than after), meta values, labels and term names. This makes it possible for authenticated attackers with contributor-level access and above to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.",
 "plugin": {
  "slug": "media-library-assistant",
  "name": "Media Library Assistant",
  "full_name": "Media Library Assistant",
  "wordpress_org": "https://wordpress.org/plugins/media-library-assistant/",
  "advisories_url": "https://wpsec.com/vuln/plugin/media-library-assistant/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/media-library-assistant"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 6.4,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "3.44",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 3.44"
  ]
 },
 "introduced_in": null,
 "fixed_in": "3.44",
 "remediation": "Update to 3.44 or later.",
 "fix_released": "2026-10-28T23:58:01+00:00",
 "published": "2026-10-30T00:43:47+00:00",
 "updated": "2026-10-29T17:47:10.114574+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-1983/",
  "https://plugins.svn.wordpress.org/media-library-assistant/tags/3.44/",
  "https://wordpress.org/plugins/media-library-assistant/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/media-library-assistant",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Low",
  "affected_versions": "None seen",
  "as_of": "2026-10-29"
 }
}