{
 "id": "WPSEC-2026-1985",
 "url": "https://wpsec.com/vuln/WPSEC-2026-1985/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-1985/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-1985/index.md",
 "title": "Supreme Modules Lite – Divi Theme, Extra Theme and Divi Builder <= 2.5.64 - Authenticated (Contributor+) Stored Cross-Site Scripting via Flip Box Perk Module Title, Subtitle and Heading Level",
 "description": "The Supreme Modules Lite plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Flip Box perk child module's title and subtitle attributes in all versions up to, and including, 2.5.64 due to insufficient output escaping. The inherited parent heading level was also not validated before being used as the HTML tag name. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.",
 "plugin": {
  "slug": "supreme-modules-for-divi",
  "name": "Supreme Modules Lite – Divi Theme, Extra Theme and Divi Builder",
  "full_name": "Supreme Modules Lite – Divi Theme, Extra Theme and Divi Builder",
  "wordpress_org": "https://wordpress.org/plugins/supreme-modules-for-divi/",
  "advisories_url": "https://wpsec.com/vuln/plugin/supreme-modules-for-divi/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/supreme-modules-for-divi"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 6.4,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "2.5.65",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 2.5.65"
  ]
 },
 "introduced_in": null,
 "fixed_in": "2.5.65",
 "remediation": "Update to 2.5.65 or later.",
 "fix_released": "2026-10-29T00:45:54+00:00",
 "published": "2026-10-30T01:42:45+00:00",
 "updated": "2026-10-29T17:37:55.358083+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-1985/",
  "https://plugins.svn.wordpress.org/supreme-modules-for-divi/tags/2.5.65/",
  "https://wordpress.org/plugins/supreme-modules-for-divi/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/supreme-modules-for-divi",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Medium",
  "affected_versions": "Medium",
  "as_of": "2026-10-29"
 }
}