# Supreme Modules Lite – Divi Theme, Extra Theme and Divi Builder <= 2.5.64 - Authenticated (Contributor+) Stored Cross-Site Scripting via Typing Effect Module Strings

- **ID:** WPSEC-2026-1986
- **Plugin:** Supreme Modules Lite – Divi Theme, Extra Theme and Divi Builder (`supreme-modules-for-divi`), https://wordpress.org/plugins/supreme-modules-for-divi/
- **Affected versions:** all versions before 2.5.65
- **Fixed in:** 2.5.65 (Update to 2.5.65 or later.)
- **Severity:** Medium 6.4 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Medium, affected versions Medium (as of 2026-10-29)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/supreme-modules-for-divi
- **Fix released:** 2026-10-29
- **Published:** 2026-10-30
- **URL:** https://wpsec.com/vuln/WPSEC-2026-1986/

## Description

The Supreme Modules Lite plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Typing Effect module's 'typing_effect' strings in all versions up to, and including, 2.5.64, due to the front-end script passing the stored strings to Typed.js with contentType set to 'html', which writes them into the page with innerHTML. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

## References

- https://wpsec.com/vuln/WPSEC-2026-1986/
- https://plugins.svn.wordpress.org/supreme-modules-for-divi/tags/2.5.65/
- https://wordpress.org/plugins/supreme-modules-for-divi/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-1986/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
