{
 "id": "WPSEC-2026-1988",
 "url": "https://wpsec.com/vuln/WPSEC-2026-1988/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-1988/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-1988/index.md",
 "title": "MultiVendorX – WooCommerce Multivendor Marketplace AI Powered Solutions <= 5.0.20 - Authenticated (Subscriber+) Stored Cross-Site Scripting via Store Description",
 "description": "The MultiVendorX – WooCommerce Multivendor Marketplace AI Powered Solutions plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the store description submitted through store registration in versions 5.0.0 through 5.0.20, due to insufficient input sanitization and output escaping. The stores REST endpoint lets any logged-in user register a store and saved the description without sanitization, and the admin store details view renders it as raw HTML. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts that execute when an administrator views the store in the dashboard.",
 "plugin": {
  "slug": "dc-woocommerce-multi-vendor",
  "name": "MultiVendorX – WooCommerce Multivendor Marketplace AI Powered Solutions",
  "full_name": "MultiVendorX – WooCommerce Multivendor Marketplace AI Powered Solutions",
  "wordpress_org": "https://wordpress.org/plugins/dc-woocommerce-multi-vendor/",
  "advisories_url": "https://wpsec.com/vuln/plugin/dc-woocommerce-multi-vendor/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/dc-woocommerce-multi-vendor"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 6.4,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": "5.0.0",
    "from_inclusive": true,
    "to": "5.0.21",
    "to_inclusive": false
   }
  ],
  "text": [
   "from 5.0.0 before 5.0.21"
  ]
 },
 "introduced_in": "5.0.0",
 "fixed_in": "5.0.21",
 "remediation": "Update to 5.0.21 or later.",
 "fix_released": "2026-10-29T01:22:54+00:00",
 "published": "2026-10-30T01:42:45+00:00",
 "updated": "2026-10-29T17:44:28.205240+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-1988/",
  "https://plugins.svn.wordpress.org/dc-woocommerce-multi-vendor/tags/5.0.21/",
  "https://wordpress.org/plugins/dc-woocommerce-multi-vendor/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/dc-woocommerce-multi-vendor",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Low",
  "affected_versions": "None seen",
  "as_of": "2026-10-29"
 }
}