# MultiVendorX – WooCommerce Multivendor Marketplace AI Powered Solutions <= 5.0.20 - Authenticated (Subscriber+) Stored Cross-Site Scripting via Store Description

- **ID:** WPSEC-2026-1988
- **Plugin:** MultiVendorX – WooCommerce Multivendor Marketplace AI Powered Solutions (`dc-woocommerce-multi-vendor`), https://wordpress.org/plugins/dc-woocommerce-multi-vendor/
- **Affected versions:** from 5.0.0 before 5.0.21
- **Fixed in:** 5.0.21 (Update to 5.0.21 or later.)
- **Severity:** Medium 6.4 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Low, affected versions None seen (as of 2026-10-29)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/dc-woocommerce-multi-vendor
- **Fix released:** 2026-10-29
- **Published:** 2026-10-30
- **URL:** https://wpsec.com/vuln/WPSEC-2026-1988/

## Description

The MultiVendorX – WooCommerce Multivendor Marketplace AI Powered Solutions plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the store description submitted through store registration in versions 5.0.0 through 5.0.20, due to insufficient input sanitization and output escaping. The stores REST endpoint lets any logged-in user register a store and saved the description without sanitization, and the admin store details view renders it as raw HTML. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts that execute when an administrator views the store in the dashboard.

## References

- https://wpsec.com/vuln/WPSEC-2026-1988/
- https://plugins.svn.wordpress.org/dc-woocommerce-multi-vendor/tags/5.0.21/
- https://wordpress.org/plugins/dc-woocommerce-multi-vendor/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-1988/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
