{
 "id": "WPSEC-2026-2016",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2016/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2016/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2016/index.md",
 "title": "The Post Grid – Shortcode, Gutenberg Blocks and Elementor Addon for Post Grid <= 7.9.7 - Unauthenticated Sensitive Information Exposure via Password-Protected Post Content",
 "description": "The The Post Grid plugin for WordPress is vulnerable to Sensitive Information Exposure via password-protected post content in all versions up to, and including, 7.9.7, due to a missing post_password_required() check in the 'full content' excerpt mode of the grid renderer and in the 'content' case of the builder data REST endpoint. This makes it possible for unauthenticated attackers to read the full content of password-protected posts on any grid set to show full content. Authenticated attackers, with contributor-level access and above, can read the content of any published password-protected post by asking the post query REST endpoint for the full content excerpt type.",
 "plugin": {
  "slug": "the-post-grid",
  "name": "The Post Grid – Shortcode, Gutenberg Blocks and Elementor Addon for Post Grid",
  "full_name": "The Post Grid – Shortcode, Gutenberg Blocks and Elementor Addon for Post Grid",
  "wordpress_org": "https://wordpress.org/plugins/the-post-grid/",
  "advisories_url": "https://wpsec.com/vuln/plugin/the-post-grid/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/the-post-grid"
 },
 "type": "SENSITIVE DATA DISCLOSURE",
 "cwe": [
  "CWE-200"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 3.7,
  "vector": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N",
  "severity": "Low"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "7.9.8",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 7.9.8"
  ]
 },
 "introduced_in": null,
 "fixed_in": "7.9.8",
 "remediation": "Update to 7.9.8 or later.",
 "fix_released": "2026-10-29T09:11:12+00:00",
 "published": "2026-10-30T09:42:55+00:00",
 "updated": "2026-10-29T17:42:06.088967+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2016/",
  "https://plugins.svn.wordpress.org/the-post-grid/tags/7.9.8/",
  "https://wordpress.org/plugins/the-post-grid/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/the-post-grid",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Medium",
  "affected_versions": "Medium",
  "as_of": "2026-10-30"
 }
}