# The Post Grid – Shortcode, Gutenberg Blocks and Elementor Addon for Post Grid <= 7.9.7 - Unauthenticated Sensitive Information Exposure via Password-Protected Post Content

- **ID:** WPSEC-2026-2016
- **Plugin:** The Post Grid – Shortcode, Gutenberg Blocks and Elementor Addon for Post Grid (`the-post-grid`), https://wordpress.org/plugins/the-post-grid/
- **Affected versions:** all versions before 7.9.8
- **Fixed in:** 7.9.8 (Update to 7.9.8 or later.)
- **Severity:** Low 3.7 (CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N)
- **Weakness:** CWE-200
- **Usage among sites WPSec scans:** plugin Medium, affected versions Medium (as of 2026-10-30)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/the-post-grid
- **Fix released:** 2026-10-29
- **Published:** 2026-10-30
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2016/

## Description

The The Post Grid plugin for WordPress is vulnerable to Sensitive Information Exposure via password-protected post content in all versions up to, and including, 7.9.7, due to a missing post_password_required() check in the 'full content' excerpt mode of the grid renderer and in the 'content' case of the builder data REST endpoint. This makes it possible for unauthenticated attackers to read the full content of password-protected posts on any grid set to show full content. Authenticated attackers, with contributor-level access and above, can read the content of any published password-protected post by asking the post query REST endpoint for the full content excerpt type.

## References

- https://wpsec.com/vuln/WPSEC-2026-2016/
- https://plugins.svn.wordpress.org/the-post-grid/tags/7.9.8/
- https://wordpress.org/plugins/the-post-grid/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2016/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
