# The Post Grid – Shortcode, Gutenberg Blocks and Elementor Addon for Post Grid <= 7.9.7 - Authenticated (Contributor+) Sensitive Information Exposure via Non-Public Post Types

- **ID:** WPSEC-2026-2017
- **Plugin:** The Post Grid – Shortcode, Gutenberg Blocks and Elementor Addon for Post Grid (`the-post-grid`), https://wordpress.org/plugins/the-post-grid/
- **Affected versions:** all versions before 7.9.8
- **Fixed in:** 7.9.8 (Update to 7.9.8 or later.)
- **Severity:** Medium 4.3 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N)
- **Weakness:** CWE-200
- **Usage among sites WPSec scans:** plugin Medium, affected versions Medium (as of 2026-10-30)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/the-post-grid
- **Fix released:** 2026-10-29
- **Published:** 2026-10-30
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2017/

## Description

The The Post Grid plugin for WordPress is vulnerable to Sensitive Information Exposure via the grid post query REST endpoints and the shortcode preview in all versions up to, and including, 7.9.7. This is due to insufficient authorization when choosing which post type to query: available_post_type() accepted any non-public post type for any user with the contributor, author, editor or administrator role, and the shortcode preview passed the requested post type straight to WP_Query. This makes it possible for authenticated attackers, with contributor-level access and above, to list and read the titles, excerpts and content of published entries of non-public post types, such as coupons or form entries registered by other plugins.

## References

- https://wpsec.com/vuln/WPSEC-2026-2017/
- https://plugins.svn.wordpress.org/the-post-grid/tags/7.9.8/
- https://wordpress.org/plugins/the-post-grid/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2017/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
