# Import and export users and customers <= 2.5.9 - Authenticated (Contributor+) Stored Cross-Site Scripting via [export-users] Shortcode 'from' Attribute

- **ID:** WPSEC-2026-2030
- **Plugin:** Import and export users and customers (`import-users-from-csv-with-meta`), https://wordpress.org/plugins/import-users-from-csv-with-meta/
- **Affected versions:** all versions before 2.5.10
- **Fixed in:** 2.5.10 (Update to 2.5.10 or later.)
- **Severity:** Medium 6.4 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-10-30)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/import-users-from-csv-with-meta
- **Fix released:** 2026-10-29
- **Published:** 2026-10-30
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2030/

## Description

The Import and export users and customers plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'from' attribute of the [export-users] shortcode in all versions up to, and including, 2.5.9, due to a date check that only looks for a date anywhere in the value and missing output escaping when the value is printed into a hidden form field. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user allowed to create users, such as an administrator, accesses or previews the injected page.

## References

- https://wpsec.com/vuln/WPSEC-2026-2030/
- https://plugins.svn.wordpress.org/import-users-from-csv-with-meta/tags/2.5.10/
- https://wordpress.org/plugins/import-users-from-csv-with-meta/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2030/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
