{
 "id": "WPSEC-2026-2031",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2031/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2031/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2031/index.md",
 "title": "WooCommerce Amazon Pay <= 2.6.3 - Unauthenticated Insecure Direct Object Reference to Order Modification via Amazon Pay Return Handler",
 "description": "The Amazon Pay for WooCommerce plugin for WordPress is vulnerable to Insecure Direct Object Reference via the Amazon Pay return handler (handle_return) in all versions up to, and including, 2.6.3, due to the handler taking the order ID from the order-pay endpoint without validating the order key or the pay_for_order capability, and not verifying that a classic checkout session was created for that order. This makes it possible for unauthenticated attackers to apply their own Amazon checkout session to another customer's pending order, overwriting its billing and shipping addresses with their own and, when the totals match, completing payment for that order.",
 "plugin": {
  "slug": "woocommerce-gateway-amazon-payments-advanced",
  "name": "WooCommerce Amazon Pay",
  "full_name": "Amazon Pay for WooCommerce",
  "wordpress_org": "https://wordpress.org/plugins/woocommerce-gateway-amazon-payments-advanced/",
  "advisories_url": "https://wpsec.com/vuln/plugin/woocommerce-gateway-amazon-payments-advanced/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/woocommerce-gateway-amazon-payments-advanced"
 },
 "type": "IDOR",
 "cwe": [
  "CWE-639"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 5.3,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "2.6.4",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 2.6.4"
  ]
 },
 "introduced_in": null,
 "fixed_in": "2.6.4",
 "remediation": "Update to 2.6.4 or later.",
 "fix_released": "2026-10-29T09:53:56+00:00",
 "published": "2026-10-30T10:50:10+00:00",
 "updated": "2026-10-29T17:42:57.051112+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2031/",
  "https://plugins.svn.wordpress.org/woocommerce-gateway-amazon-payments-advanced/tags/2.6.4/",
  "https://wordpress.org/plugins/woocommerce-gateway-amazon-payments-advanced/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/woocommerce-gateway-amazon-payments-advanced",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Low",
  "affected_versions": "Low",
  "as_of": "2026-10-30"
 }
}