{
 "id": "WPSEC-2026-2035",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2035/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2035/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2035/index.md",
 "title": "SellKit – Funnel builder and checkout optimizer for WooCommerce to sell more, faster <= 2.8.0 - Missing Authorization to Authenticated (Subscriber+) WooCommerce Plugin Installation and Activation",
 "description": "The SellKit plugin for WordPress is vulnerable to unauthorized plugin installation and activation via the 'sellkit_install_woocommerce_plugin_by_notice' AJAX action in all versions up to, and including, 2.8.0. This is due to a missing capability check on the installer() function, which verifies only the 'sellkit_admin' nonce. That nonce is printed on every wp-admin page for any logged-in user. This makes it possible for authenticated attackers, with Subscriber-level access and above, to install and activate the WooCommerce plugin on the site.",
 "plugin": {
  "slug": "sellkit",
  "name": "SellKit – Funnel builder and checkout optimizer for WooCommerce to sell more, faster",
  "full_name": "SellKit – Funnel builder and checkout optimizer for WooCommerce to sell more, faster",
  "wordpress_org": "https://wordpress.org/plugins/sellkit/",
  "advisories_url": "https://wpsec.com/vuln/plugin/sellkit/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/sellkit"
 },
 "type": "NO AUTHORISATION",
 "cwe": [
  "CWE-862"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 4.3,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "2.8.1",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 2.8.1"
  ]
 },
 "introduced_in": null,
 "fixed_in": "2.8.1",
 "remediation": "Update to 2.8.1 or later.",
 "fix_released": "2026-10-29T09:59:42+00:00",
 "published": "2026-10-30T10:50:10+00:00",
 "updated": "2026-10-29T17:46:52.724560+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2035/",
  "https://plugins.svn.wordpress.org/sellkit/tags/2.8.1/",
  "https://wordpress.org/plugins/sellkit/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/sellkit",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Low",
  "affected_versions": "Low",
  "as_of": "2026-10-30"
 }
}