# WP Tabs – Responsive Tabs Plugin for WordPress <= 3.1.7 - Authenticated (Administrator+) Arbitrary Function Call via 'type' Parameter

- **ID:** WPSEC-2026-2040
- **Plugin:** Custom Product Tabs for WooCommerce & WordPress Tabs Builder – Smart Tabs (`wp-expand-tabs-free`), https://wordpress.org/plugins/wp-expand-tabs-free/
- **Affected versions:** all versions before 3.1.8
- **Fixed in:** 3.1.8 (Update to 3.1.8 or later.)
- **Severity:** High 7.2 (CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H)
- **Weakness:** CWE-94
- **Usage among sites WPSec scans:** plugin Medium, affected versions Medium (as of 2026-10-30)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/wp-expand-tabs-free
- **Fix released:** 2026-10-29
- **Published:** 2026-10-30
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2040/

## Description

The Smart Tabs plugin for WordPress is vulnerable to Arbitrary Function Call via the 'type' parameter of the wptabspro-chosen AJAX action in all versions up to, and including, 3.1.7. This is due to the handler passing the user-supplied 'type' value to call_user_func() whenever a PHP function of that name exists, with the request-supplied 'query_args' array as its argument. This makes it possible for authenticated attackers with administrator-level access and above to call arbitrary PHP functions on the server, which can be used to escalate privileges beyond a site administrator, for example on multisite installations.

## References

- https://wpsec.com/vuln/WPSEC-2026-2040/
- https://plugins.svn.wordpress.org/wp-expand-tabs-free/tags/3.1.8/
- https://wordpress.org/plugins/wp-expand-tabs-free/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2040/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
