{
 "id": "WPSEC-2026-2061",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2061/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2061/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2061/index.md",
 "title": "Cool FormKit Lite – Advanced Form Builder for Elementor <= 2.7.9 - Authenticated (Contributor+) Stored Cross-Site Scripting via Form Field Custom ID",
 "description": "The Cool FormKit Lite – Advanced Form Builder for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the form field Custom ID used by conditional logic in all versions up to, and including, 2.7.9. This is due to insufficient input sanitization and output escaping. The Custom ID is only restricted in the Elementor editor's client-side script and is not sanitized on the server. It is used as a key in the conditional-logic data, and the front-end script places that key into HTML strings that jQuery parses. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.",
 "plugin": {
  "slug": "extensions-for-elementor-form",
  "name": "Cool FormKit Lite – Advanced Form Builder for Elementor",
  "full_name": "Cool FormKit Lite – Advanced Form Builder for Elementor",
  "wordpress_org": "https://wordpress.org/plugins/extensions-for-elementor-form/",
  "advisories_url": "https://wpsec.com/vuln/plugin/extensions-for-elementor-form/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/extensions-for-elementor-form"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 6.4,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "2.7.10",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 2.7.10"
  ]
 },
 "introduced_in": null,
 "fixed_in": "2.7.10",
 "remediation": "Update to 2.7.10 or later.",
 "fix_released": "2026-10-29T12:23:26+00:00",
 "published": "2026-10-30T12:49:34+00:00",
 "updated": "2026-10-29T17:42:51.586934+00:00",
 "also_published_as": {
  "source": "wordfence",
  "cve": [
   "CVE-2026-118500"
  ],
  "published": "2026-10-29T17:03:09+00:00"
 },
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2061/",
  "https://plugins.svn.wordpress.org/extensions-for-elementor-form/tags/2.7.10/",
  "https://wordpress.org/plugins/extensions-for-elementor-form/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/extensions-for-elementor-form",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Low",
  "affected_versions": "Low",
  "as_of": "2026-10-30"
 }
}