{
 "id": "WPSEC-2026-2062",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2062/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2062/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2062/index.md",
 "title": "PPWP – Password Protect Pages <= 1.9.26 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'ppwp' Shortcode",
 "description": "The Password Protect Pages plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's [ppwp] shortcode in all versions up to, and including, 1.9.26 due to insufficient input sanitization and output escaping when building the password form template, where user-supplied shortcode attribute values could contain placeholder tokens that were later expanded in an already-escaped context. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.",
 "plugin": {
  "slug": "password-protect-page",
  "name": "PPWP – Password Protect Pages",
  "full_name": "PPWP – Password Protect Pages",
  "wordpress_org": "https://wordpress.org/plugins/password-protect-page/",
  "advisories_url": "https://wpsec.com/vuln/plugin/password-protect-page/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/password-protect-page"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 6.4,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "1.9.27",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 1.9.27"
  ]
 },
 "introduced_in": null,
 "fixed_in": "1.9.27",
 "remediation": "Update to 1.9.27 or later.",
 "fix_released": "2026-10-29T12:54:04+00:00",
 "published": "2026-10-30T13:53:52+00:00",
 "updated": "2026-10-29T17:44:24.259924+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2062/",
  "https://plugins.svn.wordpress.org/password-protect-page/tags/1.9.27/",
  "https://wordpress.org/plugins/password-protect-page/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/password-protect-page",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Low",
  "affected_versions": "None seen",
  "as_of": "2026-10-30"
 }
}