# Post Duplicator <= 3.0.16 - Authenticated (Contributor+) Sensitive Information Exposure via Parent Posts REST Route

- **ID:** WPSEC-2026-2066
- **Plugin:** Post Duplicator (`post-duplicator`), https://wordpress.org/plugins/post-duplicator/
- **Affected versions:** from 3.0.0 before 3.0.17
- **Fixed in:** 3.0.17 (Update to 3.0.17 or later.)
- **Severity:** Medium 4.3 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N)
- **Weakness:** CWE-200
- **Usage among sites WPSec scans:** plugin Low, affected versions None seen (as of 2026-10-30)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/post-duplicator
- **Fix released:** 2026-10-29
- **Published:** 2026-10-30
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2066/

## Description

The Post Duplicator plugin for WordPress is vulnerable to Sensitive Information Exposure via the parent-posts REST route in all versions from 3.0.0 up to, and including, 3.0.16, due to the route checking only the generic edit_posts capability and returning every published, draft and private post of the requested post type without checking whether the current user may read each post. This makes it possible for authenticated attackers, with Contributor-level access and above, to list the IDs and titles of other users' draft and private posts of any post type.

## References

- https://wpsec.com/vuln/WPSEC-2026-2066/
- https://plugins.svn.wordpress.org/post-duplicator/tags/3.0.17/
- https://wordpress.org/plugins/post-duplicator/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2066/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
