# Booking System <= 2.1.0.6 - Reflected Cross-Site Scripting via 'tab' Parameter

- **ID:** WPSEC-2026-2069
- **Plugin:** WP Booking System – Booking Calendar (`wp-booking-system`), https://wordpress.org/plugins/wp-booking-system/
- **Affected versions:** all versions before 2.1.0.7
- **Fixed in:** 2.1.0.7 (Update to 2.1.0.7 or later.)
- **Severity:** Medium 6.1 (CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-10-30)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/wp-booking-system
- **Fix released:** 2026-10-29
- **Published:** 2026-10-30
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2069/

## Description

The WP Booking System plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'tab' parameter on the form edit admin page in all versions up to, and including, 2.1.0.6. This is due to insufficient escaping, as the value is only passed through sanitize_text_field, which does not encode quotes for an attribute context. This makes it possible for unauthenticated attackers to inject arbitrary web scripts that execute in an administrator's browser if they can trick the administrator into performing an action such as clicking on a link.

## References

- https://wpsec.com/vuln/WPSEC-2026-2069/
- https://plugins.svn.wordpress.org/wp-booking-system/tags/2.1.0.7/
- https://wordpress.org/plugins/wp-booking-system/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2069/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
