# Pie Register <= 3.8.4.15 - Cross-Site Request Forgery to Registration Form Deletion

- **ID:** WPSEC-2026-2124
- **Plugin:** Pie Register – User Registration, Profiles & Content Restriction (`pie-register`), https://wordpress.org/plugins/pie-register/
- **Affected versions:** all versions before 3.8.4.16
- **Fixed in:** 3.8.4.16 (Update to 3.8.4.16 or later.)
- **Severity:** Medium 4.3 (CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N)
- **Weakness:** CWE-352
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-10-30)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/pie-register
- **Fix released:** 2026-10-29
- **Published:** 2026-10-30
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2124/

## Description

The pie-register plugin for WordPress is vulnerable to Cross-Site Request Forgery via the registration form delete action in all versions up to, and including, 3.8.4.15. This is due to missing nonce validation in the pie_main() function, which runs on 'init' and deletes or disables a registration form whenever the 'prfrmid' and 'action=delete' GET parameters are present and the current user is an administrator. This makes it possible for unauthenticated attackers to delete or disable registration forms by tricking a site administrator into clicking a link or loading a page.

## References

- https://wpsec.com/vuln/WPSEC-2026-2124/
- https://plugins.svn.wordpress.org/pie-register/tags/3.8.4.16/
- https://wordpress.org/plugins/pie-register/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2124/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
