{
 "id": "WPSEC-2026-2128",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2128/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2128/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2128/index.md",
 "title": "GeoDirectory – WP Business Directory Plugin and Classified Listings Directory <= 2.8.199 - Authenticated (Subscriber+) Stored Cross-Site Scripting via AyeCode UI Popover Attributes in Listing Content",
 "description": "The GeoDirectory – WP Business Directory Plugin and Classified Listings Directory plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'data-toggle' and 'data-bs-toggle' attributes set to 'popover-html' in listing content and HTML/textarea custom fields in all versions up to, and including, 2.8.199, due to insufficient input sanitization and output escaping. The plugin's kses filtering keeps data-* attributes, and the bundled AyeCode UI script turns every element with a 'popover-html' toggle into a popover with HTML enabled and sanitization turned off, so the element's popover content is inserted into the page as raw HTML. This makes it possible for authenticated attackers with subscriber-level access and above, where front-end listing submission is enabled, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page and opens the popover.",
 "plugin": {
  "slug": "geodirectory",
  "name": "GeoDirectory – WP Business Directory Plugin and Classified Listings Directory",
  "full_name": "GeoDirectory – WP Business Directory Plugin and Classified Listings Directory",
  "wordpress_org": "https://wordpress.org/plugins/geodirectory/",
  "advisories_url": "https://wpsec.com/vuln/plugin/geodirectory/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/geodirectory"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 6.4,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "2.8.200",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 2.8.200"
  ]
 },
 "introduced_in": null,
 "fixed_in": "2.8.200",
 "remediation": "Update to 2.8.200 or later.",
 "fix_released": "2026-10-29T16:44:30+00:00",
 "published": "2026-10-30T17:44:03+00:00",
 "updated": "2026-10-30T09:24:31.089354+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2128/",
  "https://plugins.svn.wordpress.org/geodirectory/tags/2.8.200/",
  "https://wordpress.org/plugins/geodirectory/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/geodirectory",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Low",
  "affected_versions": "Low",
  "as_of": "2026-10-30"
 }
}