# Blocksy Companion <= 2.1.60 - Authenticated (Contributor+) Sensitive Information Exposure via About Me Block

- **ID:** WPSEC-2026-2136
- **Plugin:** Blocksy Companion (`blocksy-companion`), https://wordpress.org/plugins/blocksy-companion/
- **Affected versions:** all versions before 2.1.61
- **Fixed in:** 2.1.61 (Update to 2.1.61 or later.)
- **Severity:** Medium 4.3 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N)
- **Weakness:** CWE-200
- **Usage among sites WPSec scans:** plugin Medium, affected versions Medium (as of 2026-10-30)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/blocksy-companion
- **Fix released:** 2026-10-29
- **Published:** 2026-10-30
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2136/

## Description

The Blocksy Companion plugin for WordPress is vulnerable to Sensitive Information Exposure via the About Me block in all versions up to, and including, 2.1.60, due to the block's 'wp_user' attribute accepting any user ID without checking that the user has published content. The block can be rendered in a post or through the blocksy_get_dynamic_block_view AJAX action. This makes it possible for authenticated attackers, with contributor-level access and above, to expose the display name, biography, avatar and author archive slug of any user, including subscribers and customers who are not public authors.

## References

- https://wpsec.com/vuln/WPSEC-2026-2136/
- https://plugins.svn.wordpress.org/blocksy-companion/tags/2.1.61/
- https://wordpress.org/plugins/blocksy-companion/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2136/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
