# Event Tickets and Registration <= 5.30.2 - Authenticated (Contributor+) Insecure Direct Object Reference to Sensitive Attendee Information Exposure

- **ID:** WPSEC-2026-2141
- **Plugin:** Event Tickets and Registration (`event-tickets`), https://wordpress.org/plugins/event-tickets/
- **Affected versions:** from 5.10.0 before 5.30.3
- **Fixed in:** 5.30.3 (Update to 5.30.3 or later.)
- **Severity:** Medium 4.3 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N)
- **Weakness:** CWE-639
- **Usage among sites WPSec scans:** plugin Medium, affected versions Medium (as of 2026-10-30)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/event-tickets
- **Fix released:** 2026-10-29
- **Published:** 2026-10-30
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2141/

## Description

The Event Tickets and Registration plugin for WordPress is vulnerable to Insecure Direct Object Reference via the attendee details request ('tec_tickets_attendee_details') of the 'tribe_tickets_admin_manager' AJAX action in versions 5.10.0 up to, and including, 5.30.2. This is due to the admin manager handler having no capability check and the attendee details modal loading any attendee by a user-supplied ID without checking that the user can manage that attendee's event. This makes it possible for authenticated attackers with Contributor-level access and above to view details of attendees of events they do not manage, including the ticket security code, the check-in QR code, order and ticket information and check-in status.

## References

- https://wpsec.com/vuln/WPSEC-2026-2141/
- https://plugins.svn.wordpress.org/event-tickets/tags/5.30.3/
- https://wordpress.org/plugins/event-tickets/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2141/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
