# Event Tickets and Registration <= 5.30.2 - Cross-Site Request Forgery to Attendee Information Update via My Tickets Page

- **ID:** WPSEC-2026-2143
- **Plugin:** Event Tickets and Registration (`event-tickets`), https://wordpress.org/plugins/event-tickets/
- **Affected versions:** all versions before 5.30.3
- **Fixed in:** 5.30.3 (Update to 5.30.3 or later.)
- **Severity:** Medium 4.3 (CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N)
- **Weakness:** CWE-352
- **Usage among sites WPSec scans:** plugin Medium, affected versions Medium (as of 2026-10-30)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/event-tickets
- **Fix released:** 2026-10-29
- **Published:** 2026-10-30
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2143/

## Description

The Event Tickets and Registration plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 5.30.2. This is due to missing nonce validation in the update_tickets() function, which handles attendee updates submitted from the My Tickets page. This makes it possible for unauthenticated attackers to change the name, email address, opt-out setting and RSVP status of a logged-in user's attendee records via a forged request, if they can trick the user into performing an action such as clicking a link.

## References

- https://wpsec.com/vuln/WPSEC-2026-2143/
- https://plugins.svn.wordpress.org/event-tickets/tags/5.30.3/
- https://wordpress.org/plugins/event-tickets/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2143/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
