# The Events Calendar <= 6.18.2 - Unauthenticated Sensitive Information Exposure via Password-Protected Linked Organizers and Venues in REST API

- **ID:** WPSEC-2026-2146
- **Plugin:** The Events Calendar (`the-events-calendar`), https://wordpress.org/plugins/the-events-calendar/
- **Affected versions:** from 6.15.0 before 6.18.3
- **Fixed in:** 6.18.3 (Update to 6.18.3 or later.)
- **Severity:** Medium 5.3 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N)
- **Weakness:** CWE-200
- **Usage among sites WPSec scans:** plugin High, affected versions High (as of 2026-10-30)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/the-events-calendar
- **Fix released:** 2026-10-29
- **Published:** 2026-10-30
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2146/

## Description

The The Events Calendar plugin for WordPress is vulnerable to Sensitive Information Exposure via the TEC REST API single-entity read endpoint in all versions from 6.15.0 up to, and including, 6.18.2, due to the endpoint turning off the password check for the whole request (a global '__return_false' filter on 'post_password_required') once the password for the requested entity is supplied. Linked Organizers and Venues serialized in the same response therefore skip their own password check, even when they are protected by different passwords. This makes it possible for unauthenticated attackers who know the password of one event to read the protected details of linked organizers and venues whose passwords they do not know.

## References

- https://wpsec.com/vuln/WPSEC-2026-2146/
- https://plugins.svn.wordpress.org/the-events-calendar/tags/6.18.3/
- https://wordpress.org/plugins/the-events-calendar/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2146/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
