# Uncanny Toolkit for LearnDash <= 3.8.2 - Authenticated (Contributor+) Stored Cross-Site Scripting via uo_login Shortcode Label Attributes

- **ID:** WPSEC-2026-2151
- **Plugin:** Uncanny Toolkit for LearnDash (`uncanny-learndash-toolkit`), https://wordpress.org/plugins/uncanny-learndash-toolkit/
- **Affected versions:** all versions before 3.8.3
- **Fixed in:** 3.8.3 (Update to 3.8.3 or later.)
- **Severity:** Medium 6.4 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Medium, affected versions Medium (as of 2026-10-30)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/uncanny-learndash-toolkit
- **Fix released:** 2026-10-29
- **Published:** 2026-10-30
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2151/

## Description

The Uncanny Toolkit for LearnDash plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'username-label' and 'password-label' attributes of the [uo_login] shortcode in all versions up to, and including, 3.8.2. This is due to the plugin echoing these values without escaping inside a single-quoted JavaScript string in an inline script. This makes it possible for authenticated attackers with contributor-level access and above to inject arbitrary web scripts in pages. The scripts run whenever a logged-out visitor opens an injected page.

## References

- https://wpsec.com/vuln/WPSEC-2026-2151/
- https://plugins.svn.wordpress.org/uncanny-learndash-toolkit/tags/3.8.3/
- https://wordpress.org/plugins/uncanny-learndash-toolkit/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2151/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
