# CP Multi View Events Calendar <= 1.4.43 - Authenticated (Subscriber+) Stored Cross-Site Scripting via Event Color and Description

- **ID:** WPSEC-2026-2154
- **Plugin:** CP Multi View Events Calendar (`cp-multi-view-calendar`), https://wordpress.org/plugins/cp-multi-view-calendar/
- **Affected versions:** all versions before 1.4.44
- **Fixed in:** 1.4.44 (Update to 1.4.44 or later.)
- **Severity:** Medium 6.4 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Low, affected versions None seen (as of 2026-10-30)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/cp-multi-view-calendar
- **Fix released:** 2026-10-29
- **Published:** 2026-10-30
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2154/

## Description

The CP Multi View Events Calendar plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the event 'colorvalue' and 'Description' parameters in all versions up to, and including, 1.4.43, due to insufficient input sanitization and output escaping. The color value only passed through sanitize_text_field(), which does not remove quotes, and was then placed into style attributes in the calendar markup. The description could be HTML-entity-decoded and inserted into the list view without escaping. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user views the calendar.

## References

- https://wpsec.com/vuln/WPSEC-2026-2154/
- https://plugins.svn.wordpress.org/cp-multi-view-calendar/tags/1.4.44/
- https://wordpress.org/plugins/cp-multi-view-calendar/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2154/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
