{
 "id": "WPSEC-2026-2156",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2156/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2156/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2156/index.md",
 "title": "Themify Builder <= 7.8.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via Custom Font Variation Fields",
 "description": "The Themify Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Custom Font 'variations' repeater fields (such as the font style and font file URLs) in all versions up to, and including, 7.8.4, due to insufficient input sanitization and output escaping. Repeater sub-field values were saved directly from the request, even for users without the unfiltered_html capability, and were later echoed unescaped into a style element in the Custom Fonts admin list and into generated @font-face rules. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page, such as an administrator viewing the Custom Fonts list.",
 "plugin": {
  "slug": "themify-builder",
  "name": "Themify Builder",
  "full_name": "Themify Builder",
  "wordpress_org": "https://wordpress.org/plugins/themify-builder/",
  "advisories_url": "https://wpsec.com/vuln/plugin/themify-builder/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/themify-builder"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 6.4,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "7.8.5",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 7.8.5"
  ]
 },
 "introduced_in": null,
 "fixed_in": "7.8.5",
 "remediation": "Update to 7.8.5 or later.",
 "fix_released": "2026-10-29T21:34:01+00:00",
 "published": "2026-10-30T21:40:51+00:00",
 "updated": "2026-10-30T09:24:41.335531+00:00",
 "also_published_as": {
  "source": "wordfence",
  "cve": [
   "CVE-2026-115869"
  ],
  "published": "2026-10-30T15:45:06+00:00"
 },
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2156/",
  "https://plugins.svn.wordpress.org/themify-builder/tags/7.8.5/",
  "https://wordpress.org/plugins/themify-builder/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/themify-builder",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Low",
  "affected_versions": "Low",
  "as_of": "2026-10-30"
 }
}