# Themify Builder <= 7.8.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via Custom Font Variation Fields

- **ID:** WPSEC-2026-2156
- **Plugin:** Themify Builder (`themify-builder`), https://wordpress.org/plugins/themify-builder/
- **Affected versions:** all versions before 7.8.5
- **Fixed in:** 7.8.5 (Update to 7.8.5 or later.)
- **Severity:** Medium 6.4 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-10-30)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/themify-builder
- **Fix released:** 2026-10-29
- **Published:** 2026-10-30
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2156/

## Description

The Themify Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Custom Font 'variations' repeater fields (such as the font style and font file URLs) in all versions up to, and including, 7.8.4, due to insufficient input sanitization and output escaping. Repeater sub-field values were saved directly from the request, even for users without the unfiltered_html capability, and were later echoed unescaped into a style element in the Custom Fonts admin list and into generated @font-face rules. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page, such as an administrator viewing the Custom Fonts list.

Also published later by wordfence as CVE-2026-115869.

## References

- https://wpsec.com/vuln/WPSEC-2026-2156/
- https://plugins.svn.wordpress.org/themify-builder/tags/7.8.5/
- https://wordpress.org/plugins/themify-builder/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2156/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
