# EventON – Events Calendar <= 2.5.10 - Unauthenticated Reflected Cross-Site Scripting via 'l' URL Variable

- **ID:** WPSEC-2026-2168
- **Plugin:** EventON – Events Calendar (`eventon-lite`), https://wordpress.org/plugins/eventon-lite/
- **Affected versions:** all versions before 2.5.11
- **Fixed in:** 2.5.11 (Update to 2.5.11 or later.)
- **Severity:** Medium 6.1 (CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Medium, affected versions Medium (as of 2026-10-31)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/eventon-lite
- **Fix released:** 2026-10-30
- **Published:** 2026-10-31
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2168/

## Description

The EventON – Events Calendar plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the language ('l') segment of the single event page URL variable in all versions up to, and including, 2.5.10, due to insufficient input sanitization of the language value, which is set as the global calendar language and then used to build event permalinks that are printed without escaping in the event schema markup. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

## References

- https://wpsec.com/vuln/WPSEC-2026-2168/
- https://plugins.svn.wordpress.org/eventon-lite/tags/2.5.11/
- https://wordpress.org/plugins/eventon-lite/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2168/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
