# Forminator Forms <= 1.58.3 - Unauthenticated Arbitrary Shortcode Execution via Post Data Field

- **ID:** WPSEC-2026-2181
- **Plugin:** Forminator Forms – Contact Form, Payment Form & Custom Form Builder (`forminator`), https://wordpress.org/plugins/forminator/
- **Affected versions:** all versions before 1.58.4
- **Fixed in:** 1.58.4 (Update to 1.58.4 or later.)
- **Severity:** High 7.3 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L)
- **Weakness:** CWE-94
- **Usage among sites WPSec scans:** plugin Medium, affected versions Medium (as of 2026-11-03)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/forminator
- **Fix released:** 2026-11-02
- **Published:** 2026-11-03
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2181/

## Description

The Forminator Forms plugin for WordPress is vulnerable to Arbitrary Shortcode Execution via the Post Data field in all versions up to, and including, 1.58.3. This is due to the plugin saving submitted post content, titles and excerpts into the created post without neutralizing shortcode brackets, regardless of whether the submitter is allowed to edit posts. This makes it possible for unauthenticated attackers to plant arbitrary shortcodes in the created post, which execute when the post is rendered, for example when the form publishes submitted posts or when a site user previews the submitted draft. Exploitation requires a public form with a Post Data field.

## References

- https://wpsec.com/vuln/WPSEC-2026-2181/
- https://plugins.svn.wordpress.org/forminator/tags/1.58.4/
- https://wordpress.org/plugins/forminator/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2181/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
