# Post Carousel <= 4.0.9 - Unauthenticated Non-Public Post Type Information Exposure via sp_handle_post_id AJAX Action

- **ID:** WPSEC-2026-2188
- **Plugin:** Smart Post – Post Grid, Post Carousel, Post Slider Gutenberg Blocks for Blog & News (`post-carousel`), https://wordpress.org/plugins/post-carousel/
- **Affected versions:** from 4.0.0 before 4.0.10
- **Fixed in:** 4.0.10 (Update to 4.0.10 or later.)
- **Severity:** Medium 5.3 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N)
- **Weakness:** CWE-200
- **Usage among sites WPSec scans:** plugin Medium, affected versions Medium (as of 2026-11-03)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/post-carousel
- **Fix released:** 2026-10-30
- **Published:** 2026-11-03
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2188/

## Description

The Smart Post plugin for WordPress is vulnerable to Sensitive Information Exposure via the sp_handle_post_id AJAX action in all versions from 4.0.0 up to, and including, 4.0.9, due to the handler returning the title, rendered content and other data of any published post by ID without checking that its post type is public. This makes it possible for unauthenticated attackers to read data from published posts of non-public post types, such as WooCommerce coupon codes.

## References

- https://wpsec.com/vuln/WPSEC-2026-2188/
- https://plugins.svn.wordpress.org/post-carousel/tags/4.0.10/
- https://wordpress.org/plugins/post-carousel/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2188/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
