# Smart Post <= 4.0.9 - Cross-Site Request Forgery to Shortcode Import

- **ID:** WPSEC-2026-2189
- **Plugin:** Smart Post – Post Grid, Post Carousel, Post Slider Gutenberg Blocks for Blog & News (`post-carousel`), https://wordpress.org/plugins/post-carousel/
- **Affected versions:** all versions before 4.0.10
- **Fixed in:** 4.0.10 (Update to 4.0.10 or later.)
- **Severity:** Medium 4.3 (CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N)
- **Weakness:** CWE-352
- **Usage among sites WPSec scans:** plugin Medium, affected versions Medium (as of 2026-11-03)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/post-carousel
- **Fix released:** 2026-10-30
- **Published:** 2026-11-03
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2189/

## Description

The Smart Post plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 4.0.9 due to the import and export AJAX handlers only verifying the nonce when one was supplied. This makes it possible for unauthenticated attackers to import arbitrary shortcode configurations via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

## References

- https://wpsec.com/vuln/WPSEC-2026-2189/
- https://plugins.svn.wordpress.org/post-carousel/tags/4.0.10/
- https://wordpress.org/plugins/post-carousel/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2189/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
