{
 "id": "WPSEC-2026-2190",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2190/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2190/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2190/index.md",
 "title": "Post Carousel <= 4.0.9 - Authenticated (Contributor+) Stored Cross-Site Scripting via Block Attributes",
 "description": "The Smart Post plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'titleHTMLTag' attribute of the post blocks and the 'collapsibleColor' attribute of the Table of Contents block in all versions from 4.0.0 up to, and including, 4.0.9, due to insufficient input sanitization and output escaping. The title tag value is only passed through esc_html() before being used as the element name, which leaves spaces and '=' in place, and the collapsible icon color is concatenated unescaped into SVG attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.",
 "plugin": {
  "slug": "post-carousel",
  "name": "Post Carousel",
  "full_name": "Smart Post – Post Grid, Post Carousel, Post Slider Gutenberg Blocks for Blog & News",
  "wordpress_org": "https://wordpress.org/plugins/post-carousel/",
  "advisories_url": "https://wpsec.com/vuln/plugin/post-carousel/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/post-carousel"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 6.4,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": "4.0.0",
    "from_inclusive": true,
    "to": "4.0.10",
    "to_inclusive": false
   }
  ],
  "text": [
   "from 4.0.0 before 4.0.10"
  ]
 },
 "introduced_in": "4.0.0",
 "fixed_in": "4.0.10",
 "remediation": "Update to 4.0.10 or later.",
 "fix_released": "2026-10-30T13:01:57+00:00",
 "published": "2026-11-03T14:48:33+00:00",
 "updated": "2026-11-03T13:19:32.435491+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2190/",
  "https://plugins.svn.wordpress.org/post-carousel/tags/4.0.10/",
  "https://wordpress.org/plugins/post-carousel/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/post-carousel",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Medium",
  "affected_versions": "Medium",
  "as_of": "2026-11-03"
 }
}