# Wallet for WooCommerce <= 1.7.3 - Authenticated (Subscriber+) Sensitive Information Exposure via Wallet Transfer User Search

- **ID:** WPSEC-2026-2193
- **Plugin:** Wallet for WooCommerce (`woo-wallet`), https://wordpress.org/plugins/woo-wallet/
- **Affected versions:** all versions before 1.7.4
- **Fixed in:** 1.7.4 (Update to 1.7.4 or later.)
- **Severity:** Medium 4.3 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N)
- **Weakness:** CWE-200
- **Usage among sites WPSec scans:** plugin Medium, affected versions Medium (as of 2026-11-03)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/woo-wallet
- **Fix released:** 2026-10-31
- **Published:** 2026-11-03
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2193/

## Description

The Wallet for WooCommerce plugin for WordPress is vulnerable to Sensitive Information Exposure via the wallet transfer recipient search AJAX handler in all versions up to, and including, 1.7.3 due to search results being labeled with the matched user's login name and email address. This makes it possible for authenticated attackers, with subscriber-level access and above (such as customers), to obtain the username of any user whose email they know. When partial (wildcard) search is enabled by filter, attackers can enumerate the usernames and email addresses of all users, with no result limit, including users of other sites in a multisite network via the client-supplied site ID.

## References

- https://wpsec.com/vuln/WPSEC-2026-2193/
- https://plugins.svn.wordpress.org/woo-wallet/tags/1.7.4/
- https://wordpress.org/plugins/woo-wallet/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2193/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
