{
 "id": "WPSEC-2026-2194",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2194/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2194/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2194/index.md",
 "title": "Wallet for WooCommerce <= 1.7.3 - Authenticated (Subscriber+) Payment Gateway Restriction Bypass via Wallet Top-Up Orders",
 "description": "The Wallet for WooCommerce plugin for WordPress is vulnerable to a payment gateway restriction bypass in all versions up to, and including, 1.7.3 due to the \"Allowed Payment Gateways\" setting for wallet top-ups only being enforced on the cart, and not on the order-pay page, the Store API checkout route, or the REST API top-up endpoint. This makes it possible for authenticated attackers, with subscriber-level access and above, to pay for wallet top-up orders using payment gateways the store owner explicitly excluded for top-ups.",
 "plugin": {
  "slug": "woo-wallet",
  "name": "Wallet for WooCommerce",
  "full_name": "Wallet for WooCommerce",
  "wordpress_org": "https://wordpress.org/plugins/woo-wallet/",
  "advisories_url": "https://wpsec.com/vuln/plugin/woo-wallet/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/woo-wallet"
 },
 "type": "BYPASS",
 "cwe": [
  "CWE-284"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 4.3,
  "vector": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "1.7.4",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 1.7.4"
  ]
 },
 "introduced_in": null,
 "fixed_in": "1.7.4",
 "remediation": "Update to 1.7.4 or later.",
 "fix_released": "2026-10-31T14:21:41+00:00",
 "published": "2026-11-03T14:48:33+00:00",
 "updated": "2026-11-03T13:19:37.610674+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2194/",
  "https://plugins.svn.wordpress.org/woo-wallet/tags/1.7.4/",
  "https://wordpress.org/plugins/woo-wallet/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/woo-wallet",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Medium",
  "affected_versions": "Medium",
  "as_of": "2026-11-03"
 }
}