# Wallet for WooCommerce <= 1.7.3 - Authenticated (Subscriber+) Payment Gateway Restriction Bypass via Wallet Top-Up Orders

- **ID:** WPSEC-2026-2194
- **Plugin:** Wallet for WooCommerce (`woo-wallet`), https://wordpress.org/plugins/woo-wallet/
- **Affected versions:** all versions before 1.7.4
- **Fixed in:** 1.7.4 (Update to 1.7.4 or later.)
- **Severity:** Medium 4.3 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N)
- **Weakness:** CWE-284
- **Usage among sites WPSec scans:** plugin Medium, affected versions Medium (as of 2026-11-03)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/woo-wallet
- **Fix released:** 2026-10-31
- **Published:** 2026-11-03
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2194/

## Description

The Wallet for WooCommerce plugin for WordPress is vulnerable to a payment gateway restriction bypass in all versions up to, and including, 1.7.3 due to the "Allowed Payment Gateways" setting for wallet top-ups only being enforced on the cart, and not on the order-pay page, the Store API checkout route, or the REST API top-up endpoint. This makes it possible for authenticated attackers, with subscriber-level access and above, to pay for wallet top-up orders using payment gateways the store owner explicitly excluded for top-ups.

## References

- https://wpsec.com/vuln/WPSEC-2026-2194/
- https://plugins.svn.wordpress.org/woo-wallet/tags/1.7.4/
- https://wordpress.org/plugins/woo-wallet/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2194/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
