{
 "id": "WPSEC-2026-2195",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2195/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2195/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2195/index.md",
 "title": "Wallet for WooCommerce <= 1.7.3 - Authenticated (Subscriber+) Wallet Balance Manipulation via REST Top-Up 'currency' Parameter",
 "description": "The Wallet for WooCommerce plugin for WordPress is vulnerable to wallet balance manipulation via the 'currency' parameter of the terawallet/v1/me/topup REST endpoint in all versions up to, and including, 1.7.3, due to the endpoint accepting any three-letter currency code for the top-up order while the wallet credit converts the order currency to the store base currency at a 1:1 rate whenever no exchange rate is known (the default when no supported currency switcher is active), and comparing the minimum/maximum top-up limits against the unconverted amount. This makes it possible for authenticated attackers, with subscriber-level access and above, to pay for a top-up in a low-value currency and receive the same nominal amount as wallet credit in the store currency, provided the payment gateway accepts that currency.",
 "plugin": {
  "slug": "woo-wallet",
  "name": "Wallet for WooCommerce",
  "full_name": "Wallet for WooCommerce",
  "wordpress_org": "https://wordpress.org/plugins/woo-wallet/",
  "advisories_url": "https://wpsec.com/vuln/plugin/woo-wallet/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/woo-wallet"
 },
 "type": "BYPASS",
 "cwe": [
  "CWE-840"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 5.3,
  "vector": "CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "1.7.4",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 1.7.4"
  ]
 },
 "introduced_in": null,
 "fixed_in": "1.7.4",
 "remediation": "Update to 1.7.4 or later.",
 "fix_released": "2026-10-31T14:21:41+00:00",
 "published": "2026-11-03T14:48:33+00:00",
 "updated": "2026-11-03T13:19:37.610674+00:00",
 "also_published_as": null,
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2195/",
  "https://plugins.svn.wordpress.org/woo-wallet/tags/1.7.4/",
  "https://wordpress.org/plugins/woo-wallet/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/woo-wallet",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Medium",
  "affected_versions": "Medium",
  "as_of": "2026-11-03"
 }
}