# AnyWhere Elementor <= 1.3.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via Widget Settings

- **ID:** WPSEC-2026-2198
- **Plugin:** Dynific Addons for Elementor (formerly Anywhere Elementor) (`anywhere-elementor`), https://wordpress.org/plugins/anywhere-elementor/
- **Affected versions:** all versions before 1.3.1
- **Fixed in:** 1.3.1 (Update to 1.3.1 or later.)
- **Severity:** Medium 6.4 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Medium, affected versions Medium (as of 2026-11-03)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/anywhere-elementor
- **Fix released:** 2026-11-02
- **Published:** 2026-11-03
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2198/

## Description

The Dynific Addons for Elementor (formerly Anywhere Elementor) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via several widget settings in all versions up to, and including, 1.3.0. Examples are the Post Meta labels and separators, the Post Navigation labels and separator, the Post Title 'title_tag' setting and the Post Author 'author_tag' and 'icon' settings. The cause is insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

## References

- https://wpsec.com/vuln/WPSEC-2026-2198/
- https://plugins.svn.wordpress.org/anywhere-elementor/tags/1.3.1/
- https://wordpress.org/plugins/anywhere-elementor/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2198/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
