# AnyWhere Elementor <= 1.3.0 - Authenticated (Subscriber+) SQL Injection via 'q' Parameter

- **ID:** WPSEC-2026-2200
- **Plugin:** Dynific Addons for Elementor (formerly Anywhere Elementor) (`anywhere-elementor`), https://wordpress.org/plugins/anywhere-elementor/
- **Affected versions:** all versions before 1.3.1
- **Fixed in:** 1.3.1 (Update to 1.3.1 or later.)
- **Severity:** Medium 6.5 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N)
- **Weakness:** CWE-89
- **Usage among sites WPSec scans:** plugin Medium, affected versions Medium (as of 2026-11-03)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/anywhere-elementor
- **Fix released:** 2026-11-02
- **Published:** 2026-11-03
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2200/

## Description

The Dynific Addons for Elementor (formerly Anywhere Elementor) plugin for WordPress is vulnerable to SQL Injection via the 'q' parameter of the ae_prev_post AJAX action in all versions up to, and including, 1.3.0. This is due to the search term being concatenated into the posts_where clause after only esc_like(), which does not escape quotes, and to the handler checking only a nonce that is printed to every front-end visitor, with no capability check. This makes it possible for authenticated attackers, with Subscriber-level access and above, to append additional SQL queries to existing queries and extract sensitive information from the database.

## References

- https://wpsec.com/vuln/WPSEC-2026-2200/
- https://plugins.svn.wordpress.org/anywhere-elementor/tags/1.3.1/
- https://wordpress.org/plugins/anywhere-elementor/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2200/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
