# AnyWhere Elementor <= 1.3.0 - Authenticated (Contributor+) Information Exposure via dynific_template Shortcode

- **ID:** WPSEC-2026-2201
- **Plugin:** Dynific Addons for Elementor (formerly Anywhere Elementor) (`anywhere-elementor`), https://wordpress.org/plugins/anywhere-elementor/
- **Affected versions:** from 1.3 before 1.3.1
- **Fixed in:** 1.3.1 (Update to 1.3.1 or later.)
- **Severity:** Medium 4.3 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N)
- **Weakness:** CWE-200
- **Usage among sites WPSec scans:** plugin Medium, affected versions Medium (as of 2026-11-03)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/anywhere-elementor
- **Fix released:** 2026-11-02
- **Published:** 2026-11-03
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2201/

## Description

The Dynific Addons for Elementor (formerly Anywhere Elementor) plugin for WordPress is vulnerable to Information Exposure via the 'post_id' attribute of the dynific_template and INSERT_ELEMENTOR shortcodes in all versions up to, and including, 1.3.0. This is due to the shortcode rendering the template in the context of any supplied post ID without checking the post's status or the viewer's permissions. This makes it possible for authenticated attackers, with Contributor-level access and above, to display the content of private, draft and password-protected posts.

## References

- https://wpsec.com/vuln/WPSEC-2026-2201/
- https://plugins.svn.wordpress.org/anywhere-elementor/tags/1.3.1/
- https://wordpress.org/plugins/anywhere-elementor/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2201/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
