# Directorist: AI-Powered Business Directory, Listings & Classified Ads <= 8.10.6 - Authenticated (Contributor+) Stored Cross-Site Scripting via Single Listing Shortcode Placeholder

- **ID:** WPSEC-2026-2227
- **Plugin:** Directorist: AI-Powered Business Directory, Listings & Classified Ads (`directorist`), https://wordpress.org/plugins/directorist/
- **Affected versions:** all versions before 8.10.7
- **Fixed in:** 8.10.7 (Update to 8.10.7 or later.)
- **Severity:** Medium 6.4 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Medium, affected versions Medium (as of 2026-11-03)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/directorist
- **Fix released:** 2026-11-01
- **Published:** 2026-11-03
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2227/

## Description

The Directorist plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the single listing dummy shortcode placeholder in all versions up to, and including, 8.10.6 due to insufficient output escaping of the shortcode name and its attributes when the placeholder is rendered. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses a page displaying the injected placeholder.

## References

- https://wpsec.com/vuln/WPSEC-2026-2227/
- https://plugins.svn.wordpress.org/directorist/tags/8.10.7/
- https://wordpress.org/plugins/directorist/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2227/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
