# WP Photo Album Plus <= 9.3.05.003 - Unauthenticated Stored Cross-Site Scripting via User-Agent Header

- **ID:** WPSEC-2026-2250
- **Plugin:** WP Photo Album Plus (`wp-photo-album-plus`), https://wordpress.org/plugins/wp-photo-album-plus/
- **Affected versions:** all versions before 9.3.06.001
- **Fixed in:** 9.3.06.001 (Update to 9.3.06.001 or later.)
- **Severity:** High 7.2 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N)
- **Weakness:** CWE-79
- **Usage among sites WPSec scans:** plugin Low, affected versions Low (as of 2026-11-03)
- **Attack surface analysis:** https://attacksurface.wpsec.com/plugin/wp-photo-album-plus
- **Fix released:** 2026-10-30
- **Published:** 2026-11-03
- **URL:** https://wpsec.com/vuln/WPSEC-2026-2250/

## Description

The WP Photo Album Plus plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the User-Agent header in all versions up to, and including, 9.3.05.003 due to insufficient input sanitization when session data is stored and insufficient output escaping when the session list is displayed in the admin maintenance popup. This makes it possible for unauthenticated attackers to inject arbitrary web scripts that will execute whenever an administrator views the session list on the maintenance page.

## References

- https://wpsec.com/vuln/WPSEC-2026-2250/
- https://plugins.svn.wordpress.org/wp-photo-album-plus/tags/9.3.06.001/
- https://wordpress.org/plugins/wp-photo-album-plus/

Source: WPSec, https://wpsec.com/vuln/WPSEC-2026-2250/

License: CC BY 4.0 (https://creativecommons.org/licenses/by/4.0/). Free to use, share and adapt, also commercially, if you credit WPSec and link to this advisory.
