{
 "id": "WPSEC-2026-2257",
 "url": "https://wpsec.com/vuln/WPSEC-2026-2257/",
 "json_url": "https://wpsec.com/vuln/WPSEC-2026-2257/advisory.json",
 "markdown_url": "https://wpsec.com/vuln/WPSEC-2026-2257/index.md",
 "title": "FeedWordPress <= 2026.0517 - Unauthenticated Stored Cross-Site Scripting via Syndicated Feed Content",
 "description": "The FeedWordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via syndicated feed item content in all versions up to, and including, 2026.0517, due to the plugin deliberately removing WordPress's kses filters from content_save_pre before saving syndicated posts. As a result, raw feed HTML such as script tags, event handler attributes and javascript: URLs is stored without sanitization. This makes it possible for unauthenticated attackers who control, or can inject content into, a feed the site syndicates (for example a compromised feed or one that republishes user-submitted input) to inject arbitrary web scripts into posts that execute whenever a user, including an administrator, views the affected post.",
 "plugin": {
  "slug": "feedwordpress",
  "name": "FeedWordPress",
  "full_name": "FeedWordPress",
  "wordpress_org": "https://wordpress.org/plugins/feedwordpress/",
  "advisories_url": "https://wpsec.com/vuln/plugin/feedwordpress/",
  "attacksurface": "https://attacksurface.wpsec.com/plugin/feedwordpress"
 },
 "type": "XSS",
 "cwe": [
  "CWE-79"
 ],
 "cve": [],
 "cvss": {
  "version": "3.1",
  "score": 5.4,
  "vector": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N",
  "severity": "Medium"
 },
 "affected": {
  "ranges": [
   {
    "from": null,
    "from_inclusive": true,
    "to": "2026.1016",
    "to_inclusive": false
   }
  ],
  "text": [
   "all versions before 2026.1016"
  ]
 },
 "introduced_in": null,
 "fixed_in": "2026.1016",
 "remediation": "Update to 2026.1016 or later.",
 "fix_released": "2026-10-30T10:25:22+00:00",
 "published": "2026-11-03T14:48:33+00:00",
 "updated": "2026-11-03T13:21:50.231533+00:00",
 "also_published_as": {
  "source": "wordfence",
  "cve": [
   "CVE-2026-110530"
  ],
  "published": "2026-10-30T20:11:36+00:00"
 },
 "references": [
  "https://wpsec.com/vuln/WPSEC-2026-2257/",
  "https://plugins.svn.wordpress.org/feedwordpress/tags/2026.1016/",
  "https://wordpress.org/plugins/feedwordpress/"
 ],
 "attacksurface_url": "https://attacksurface.wpsec.com/plugin/feedwordpress",
 "source": "WPSec",
 "license": {
  "name": "CC BY 4.0",
  "url": "https://creativecommons.org/licenses/by/4.0/"
 },
 "usage": {
  "plugin": "Low",
  "affected_versions": "Low",
  "as_of": "2026-11-03"
 }
}